KAGG Compatibility

Lýsing

WordPress is not fully compatible with PHP 8.0 or 8.1. All remaining known PHP 8.1 issues are deprecation notices.

The same is related to many popular plugins such as WooCommerce, Jetpack and others. Mainly, they produce deprecation notices from the Action Scheduler library.

Features

  • Plugin blocks all deprecation notices from WordPress core, WooCommerce, JetPack and many others using Action Scheduler library.
  • Plugin filters out errors from these libraries only. Errors produced by the user code are not blocked, which helps to debug.
  • During activation, plugin installs a mu-plugin kagg-compatibility-error-handler.php into the /wp-content/mu-plugins/ folder. It contains the error handler, which loads earlier than any plugin or theme.

Plugin Support

Uppsetning

  1. Upload kagg-compatibility folder to the /wp-content/plugins/ directory.
  2. Activate the plugin through the ‘Plugins’ menu in WordPress.

Can I contribute?

Yes, you can!

Umsagnir

Skoða 1 umsögn

Þátttakendur & höfundar

“KAGG Compatibility” er opinn hugbúnaður. Eftirfarandi aðilar hafa lagt sitt af mörkum við smíði þessarar viðbótar.

Höfundar

Translate “KAGG Compatibility” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Breytingarsaga

1.1.0

  • Tested with WordPress 6.0

1.0.1

  • Fixed creation of the mu-plugin folder if it does not exist.

1.0.0

  • Initial release